一千萬個為什麽

搜索
當前位置: 首頁 > Telnet超時

Telnet超時

我正在為一個班/實習項目工作。在其中,我需要配置路由器以接受telnet。連接剛剛超時。

為了解釋,我在遠程登錄的路由器和我從遠程登錄的路由器之間有一個非托管交換機。但是,由於它沒有管理,我懷疑這是問題所在。為了顯示命令,這裏它們是,但是為了安全起見改變了IP地址。真正的ips是公共的,我需要一個telnet才能從任何地方完成:

access-list 100 permit tcp any eq 23 any eq 23
!
enable password xxxxxx
!
interface Ethernet0/0
 ip address 127.12.168.5 255.255.255.128
 ip access-group 100 in
 ip access-group 100 out
 no keepalive
!
line vty 0 4
 access-class 100 in
 access-class 100 out
 exec
 exec-timeout 0
 password xxxxxx
 login

任何幫助解釋這一點將非常感激。我有能力遠程進入管理路由器的設備,所以時間不是問題。只要我在,我就可以繼續努力。

提前感謝您提供的任何幫助。如果需要,我可以提供更多的腳本,盡管我從與我的知識相關的內容開始。但是,與我提供的內容一樣,出於安全原因,IP地址將被更改。

最佳答案

通常,學校工作問題在這裏是偏離主題的,但在這種情況下我會例外:

  1. 刪除訪問列表100和所有訪問類/組語句。您編寫訪問列表的方式,您需要源端口和目標端口都是23.Telnet客戶端使用大於1024的短暫源端口(大於Windows的49152),因此沒有任何東西可以通過您的訪問列表。

  2. 好消息是您不需要訪問列表。只需在vty語句下添加此行:

  line vty 0 4
運輸輸入telnet
</代碼> 

這將允許telnet訪問設備。

如果您確實要限制只訪問某些IP地址,可以配置如下標準訪問列表:

ip access-list standard TELNET-ACCESS
! this allows a single host
permit 1.2.3.4
! this allows a whole /24 subnet
permit 1.2.3.0 0.0.0.255

line vty 0 4
access-class TELNET-ACCESS in

轉載註明原文: Telnet超時